INSTALLATION DOCUMENTS BY RAVI

Thursday, July 26, 2018

Apache superset installation and configuration

Installing prerequisites:


Python:





Cryptography:












Virtualenv:


















Setting virtualenv environment:







Activating virtualenv:




Upgrading setup tools:







Installing superset:

















Creating admin user for superset:












Getting error “no module named pandas.core”

Upgrading pandas to resolve the issue:

































Again try to create the admin user:








Upgrading the superset database:










Getting error “ImportError: cannot import name ‘ExtDeprecationWarning”

To resolve this install the prerequisites in the Requirements.txt file as below:

Note: If the file is not there create the file and add the below requisites in it.

Requirements.txt
bleach==2.1.2
boto3==1.4.7
botocore==1.7.48
celery==4.2.0
colorama==0.3.9
cryptography==1.9
flask==0.12.2
flask-appbuilder==1.10.0
flask-caching==1.4.0
flask-compress==1.4.0
flask-migrate==2.1.1
flask-testing==0.7.1
flask-wtf==0.14.2
flower==0.9.2
future==0.16.0
geopy==1.11.0
gunicorn==19.8.0
humanize==0.5.1
idna==2.6
isodate==0.6.0
markdown==2.6.11
pandas==0.23.1
parsedatetime==2.0.0
pathlib2==2.3.0
polyline==1.3.2
pydruid==0.4.4
pyhive==0.5.1
python-dateutil==2.6.1
python-geohash==0.8.5
pyyaml==3.12
requests==2.18.4
simplejson==3.15.0
six==1.11.0
sqlalchemy==1.2.2
sqlalchemy-utils==0.32.21
sqlparse==0.2.4
tableschema==1.1.0
thrift==0.11.0
thrift-sasl==0.3.0
unicodecsv==0.14.1
unidecode==1.0.22
contextlib2==0.5.5

















After the requirements installed successfully upgrade superset database again































Loading the default examples:


















Initializing the superset:














Starting the superset server:














Accessing superset console:














































5 comments:

  1. It’s nearly impossible to find well-informed people in this particular topic, but you seem like you know what Big
    you’re talking about! Thanks

    ReplyDelete

  Opatch reports 'Cyclic Dependency Detected' error when patching ODI   Issue: When applying a Patch Set Update (PSU) to WebLogic Se...